Why Vista sucks (a bit) because of you and me

Sound mixer in Windows Vista

I’ve seen this bug in Vista for at least 3 months. I wouldn’t be surprised if this had lower priority than a new boot screen. To our disadvantage, it doesn’t obstruct functionality, so no one will proactively fix it. But, it’s always reproducible, visible and annoying. There’s plenty more where this came from. Believe it or not, because of Gartner, Apple, Microsoft’s shareholders, Microsoft’s directors, OEMs, you and me, this won’t be fixed.

Why? Because we all want Vista to be finalized, pressed, packaged, shipped, stocked and sold tomorrow.

No more posters, Apple.

Edit: Apparently I’m the only person seeing having this bug. But this still applies plenty of other small bugs. I’m not the only person seeing this.

55 insightful thoughts

  1. I’m currently running 5744 and I see it every time when I open up the mixer. Sometimes, usually when I open it for the first time after loading Windows, instead of the black being around the slider, I see a bold, black border around the mute button and around the words.

  2. I don’t see that, but I see weird one-item menu when I click Devices in that window. It’s wrongly padded (I assume it’s for selecting a soundcard if you have more than one). And I still don’t get that one-item menu in Windows DVD Maker (DVD Menus, click it and it gives you exactly one item).

  3. It’s been reported a half a dozen times (both internally and externally), and we’ve never had an even vaguely reliable repro case. It is currently believed to be a video driver issue, not a volume control issue (not that it really matters).

  4. I feel like the the double-click behavior of all the new notification area icons is broken. Namely: There is none. Double-clicking does the same thing as single-clicking, which means you lose a chance to get to a feature quickly. Double clicking the volume icon should bring up the full mixer, or the Playback devices control, just like double-clicking the Network icon should bring up the Network and Sharing Center. It’s an annoying ommission, because no matter how many months I’ve been using Vista, I keep expecting it to behave differently.

  5. They can take as long as they want, just as long as I don’t have to download any 200mb service packs within the next 2 years (My connection is incapable of handling such large files, thanks Optus!)…

  6. I personally have no problem waiting for Microsoft to spend time tweaking the user interface until no such bugs exist – even if it takes an extra 3 or 4 months.

    I probably won’t be switching over to Vista until I get a new PC with an auto restore cd/function (that will allow me to bypass Vista’s ridiculous activation trap) and that most likely won’t happen til’ mid-2007.

    From a functionality standpoint though and looking at this particular issue, how DOES having separate volume controls help the end user? Instead of adjusting one universal volume control now I have to locate a certain app and adjust it individually? Sounds cumbersome to me.

  7. I get this every time too and it drives me crazy. I wish Microsoft would have delayed Vista, just a couple of months, so that they could have fixed issues like this. No, they may not be big issues, but still…

  8. No its not. Its a feature that should have been here years ago.
    And there STILL is a Master Volume Control. That will control everything in one go. Also it will keep the same volume level ratios between each app.

    Dont you ever have Music cranked up heaps and then BING!! a bloody msn alert hammers you. Or you are playing a game and want an easy way to turn its volume down and have some mp3s going on the background?

    This is all now easly managed via this new design.
    I think its awesome.

  9. Ok… never seen this? What build this? Your WMP is different than RC1, any way Windows Update should fix this shortly after the realize at Microsoft,(HOPEFULLY fix this)

  10. you think maybe it’s a dwm glitch? or does that not count because it’s in the client area?

    i personally haven’t seen this particular problem, but the Playback Devices control panel thingee hangs (4evah) when i change (and not apply) speaker setup or output quality.

    maybe it’s the NGO SB Live! drivers…

  11. That’s why they’ve decided to release Vista to the corporate world first. It’s not likely that they’re going to listen to music or fiddle around the control panel. I’m sure by Jan MS will be able to fix this problem

  12. Just remember the corporate release and the public release is exactly the same build.
    So all fixes like this will be via windows update.

  13. This, and the fact I can’t event watch videos on 5700 builds because after x amount of time the display driver will crash- sometimes Vista recovers (which is cool) but other times it just sits there on a blank screen :(

  14. ^ This is on an nVidia 7800gtx, admittedly since day 1 it had the tendancy to do very light ‘artifacting’ such as polygons getting dragged off screen for a second, so this may have something to do with it.

  15. But Long, what is that freaking line , did you notice that, horizontal line which is there in between all three volume controls? In the middle a small H-line and then at the bottom. got any bright ideas?

  16. Ok people, of you having this problem how many of you are using Logitech Setpoint drivers. I’ve pretty much tested several different configurations, and to my own disbelief it hasn’t been a sound card driver issue, nor a video card issue, but a MOUSE DRIVER issue. Ok, ok, not so much a mouse driver issue as its been an issue with the setpoint software specifically. Is this isolate to Setpoint?? My guess would be no, I believe you might see this behavior with anything that performs a video overlay function. Can anyone supply additional feeback? Thanks.

  17. WINDOWS VISTA IS A NIGHTMARE!

    NEWER ISN’T ALWAYS BETTER!

    TRUST ME WHEN I SAY I REALLY KNOW MY WAY AROUND A COMPUTER.

    USING 2 OF THE EXACT SAME BRAND NEW GATEWAY LAPTOPS FOR MY BUSINESS – (BOTH WITH IDENTICAL SPECS) ONE WITH WINDOWS AND THE OTHER VISTA, THE VISTA HAS MAJOR UNACCEPTABLE SOUND ISSUES, COMPATIBILITY PROBLEMS AND MANY OTHER ISSUES THAT THE WINDOWS XP LATOP DIDN’T.

    VISTA IS A MAJOR SYSTEM HOG USING WAY TOO MUCH MEMORY TO RUN IT.
    MAKING IT SLOWER THAN THE XP RIGHT OFF THE BAT.

    NO LIE IT TOOK ME 48 HOURS JUST TO “SCAN” A FILE WITH VISTA THAT TOOK WINDOWS XP ONLY 8 HOURS. KEEP IN MIND BOTH LAPTOPS HAVE 2 GIGS OF RAM.

    VISTA IS VERY CONFUSING.

    TO GET TO CONTROL PANEL ICONS IN VISTA, IT TAKES 3 TIMES AS LONG AS XP HAVING TO CLICK THROUGH SO MANY PAGES TO GET TO WHERE YOU WANT TO GO. IT IS VERY ANNOYING AND TIME CONSUMING.

    EVERY PROGRAM I INSTALLED HAD TO BE MADE COMPATIBLE WITH WINDOWS XP.
    (IT WAS NOT FUN AT ALL)

    I GOT ENDLESS SECURITY AND OTHER WARNING POP UPS UNTIL I DISABLED UAC.

    THERE ARE ALMOST NO SOUND OPTIONS AND CHOICES IN VISTA. (AND WHO KNOWS WHAT OTHER OPTIONS)

    THERE ARE MANY OTHER BAD THINGS I COULD POST ABOUT VISTA BUT LONG POSTS DON’T GET READ.

    I HAVE SEEN NO BENEFITS AT ALL FROM VISTA, ONLY HEADACHE AND A MAJOR WASTE OF TIME.

    TRUST ME WHEN I SAY, THE WORLD IS NOT READY FOR VISTA AND VISTA IS NOT READY FOR THE WORLD.

    NEXT TIME YOU BUY A BRAND NEW COMPUTER, INSIST IT HAS WINDOWS XP.
    JUST DO NOT BUY IT WITH VISTA UNLESS YOU ARE GOING TO WIPE IT CLEAN AND USE WINDOWS XP, PROVIDING IT IS ABLE TO EVEN RUN XP.

    LONG LIVE WINDOWS XP AND LONG LIVE THE COMPUTERS ABLE TO RUN IT!!!!

    ~GARY

  18. I have Setpoint and I have this problem as well. Video card is an ATI x1400. I wish there was a decent alternative to Setpoint. :/

  19. Is anyone able to disable hardware acceleration in the advanced tab of their display settings? I can’t, probably because I’m using Beta nVidia drivers, but maybe that would help with the problem?

    I’m getting it too and it’s really annoying!

  20. I think the problem is SetPoint by Logitech. I’ve installed it and after few seconds the bug appears.

    Maybe logitech can try to fix it.

  21. This happen because the driver does not return the status of some channels. Update to Vista signed drivers and problem is solved. (This is not a graphic problem)

  22. To fix SetPoints you have to go Logitech. If you have the Logitech MX-3200 Keyboard it is only suppose to work with Windows Xp and Xp pro but will work with Vista but a real pain in the ass to set up right, so I sent it back and got the Logitech MX-5000 with rechargeable mouse. I like it much better.

  23. Gary

    You talk so much BS

    If you reallly really knew your way aroubnd a PC
    you would know what laptops and PC hardware to buy FIRST
    you make sweeping statements

    I have built a fair few towers with Vista / MCE / re ote cameras / HDTV

    on the right hardware ( DuR :p ) Vista is BRILLIANT

    you are a idiot imho

    Hammer

  24. This is the only place on the internet that i see any recognition of this problem.

    It’s just embarrassing that such a simple dialogue box has a reproducible visual error, especially such a prominent dialogue box.

  25. the whole thing sticks none of my devives work.
    sandisksskype wifi phone
    none of my devices work right anymore i HATE IT

  26. I have this problem as well, as of 9/19/2007, with a brand-new MX3200 cordless desktop and a recent (last week – 9/22) clean install of Vista on modern hardware.

    FWIW, though I don’t think this is a video driver issue, I am running a 8800 GTS with the beta drivers recommended for Bioshock.

    Call me a cheese, but I do like the fact that I can use the Aero / Glass window flipper right from a single keypress on the 3200!

    -astro

  27. Update:

    This problem seems to be a result of anything doing a DD overlay on the Aero desktop. For those of you not using Logitech Setpoint, the above pictured issue can be replicated by downloading FRAPs. Odd thing is the overlay doesn’t even have to be active, the corruption will occur irregardless. That being said, I’m not sure if this is a video driver issue or a coding issue for the applications performing the overlay functions. Anyone on newer hardware/drivers ie. 8 series geforce? If so would you mind loading FRAPs and seeing if your having the problem. I can attest that this is easily recreated on 7 series and below geforce cards using FRAPs as a test. I’ve verified with 5 separate PCs so far.

  28. READ THIS

    It is because of Logitech’s Setpoint…

    Uninstalled it and it does not display anymore.

    My setup… Vista x64 updated…+ setpoint 4.40 x64

  29. I guess it’s not directly Vista related problem, one of my computers at home have the exact same problem while the other does not.
    Problem machine: Asus P5KC mobo with Hi definition audio from realtek, Q6600 processor, Splarkle 6800 GT Nvidia based card
    Normal machine: ASUS K8V deluxe mobo with AC97 sound AMD 64 3400 processor (754 pin), Leadtek 6600 GT Nvidia based card (+a non working flyvideo tv card+ a modem)

    I myself hate Vista for several issues you ve stated above, but unfortunately support for new technologies seem to be on the new baby – not XP. Even the crystal clear sound I get from the “no setting sound card” keeps me on the Vista side. A same audio hardware may sound distinguishably different on Vista. I hear sounds that I ve never heard, from very old sound files on my system.

    Hope they make it a lot reliable soon.

  30. I just got my Dell Latitude E6400 laptop. It has Dell Control Point installed (which is among other things the on screen display if you enable/disable keyboard backlit and ambient light sensor, screen brightness indicator, and volume control display information. When installed this issue occurs. So it’s not only Logitech SetPoint. The laptop has the IDT sound card.

Leave a Reply